
Excel Overview


Overview of Using Excel 

Excel is a "spreadsheet" program. Spreadsheets are often used for financial or business information such as budgets, and for any data in the form of a table of rows and columns. You can label and format data to present it as information. Formulas can calculate new data using data already entered. You can also use Excel to make charts such as pie charts and bar graphs, based on all the data, that which is entered directly, and that which is calculated using formulas. In Excel, a table of rows and columns is called a worksheet. This comes from accounting, where these tables are used for budgeting and other types of financial analysis. A *.xls file is a workbook, which can contain several worksheets.

This in-class exercise will not be enough for you to learn Excel. This is only an introduction. The lab assignments will take you through the details.

I. 
Worksheet - a series of cells arranged in rows and columns, with data in the cells

A. Layout is freeform - you design it.

B. Rows are labeled with numbers and column with letters, cell is labeled by row and column, e.g. A1, B3.

1. Cell label appears in Name Box in upper left
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2. When we get to the database Access, you will be able to change the column headings, but in Excel they are fixed as A, B, C, etc.

C. What can you put in a cell?

1. Usually numerical data is the most important cell content (budget)

2. Can also be text - labels

3. Other...

D. Can be formula to calculate a result from other numbers. In a formula, you use one or more cell references (references to other cells) and mathematical symbols to calculate a new value based on the data in other cells. 

1. Much less common but can be useful: text formulas, for example to combine "first name" and "last name" into "name" (not part of this course).

II. 
Selecting - act on the selection as a whole, usually for formatting

A. Click in a cell to select it

B. Click on a column or a row label to select the whole row or column

C. Drag over a range of cells, rows or columns to select the whole group, say B3:F6.

D. Hold down <Ctrl> and click to add to selection (or, if it is already selected, to remove it from the selection)

E. Selected cells are indicated by: 

1. Heavier outline

2. Row and column labels highlighted

3. First cell in a group is shown in the Name Box at the upper left of the Excel window

III. 
Entering data in a cell. 

III. (See illustration below for entering information into cell G6.) Click in cell F1 to select it, type Month and tap <Enter> or arrow down to enter the information. Notice the insertion point in cell G6 in the figure - data entry is still going on; the final 0 has not been entered yet.
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III. Finish entering the data as in the figure above. (Enter $250,000 into G6 and tap <enter>.)

III. Finishing data entry - just typing the data does not finish entering it in a cell, you must finish the data entry by one of: 

III. Tap the <enter> key

III. Click on another cell

III. Tap an arrow key to move to another cell.
NOTE: when you edit a cell, the arrow keys will be used for keyboard editing, not for finishing entry, so you cannot always rely on this method of finishing entry.

III. Confirming data entry - you can confirm that data is entered when the data is displayed but the cell is not selected.

III. Column F, cells 1 through 6 and cell G1 are labels; cells 2 through 6 in Column G are numbers. Both are data to Excel - it doesn't "know" that "April" is a label for "$200,000."

III. If you are following along, for safekeeping, save this Excel spreadsheet to your floppy diskette.

IV. 
Saving Excel files

IV. Use menu item File > Save As... Save and Save As... work the same way as in Word

IV. File name should remind you of what is in the file

IV. Default for extension in File / Save As... is .xls - do not change this

IV. Will also Save As HTML... - HTML table. Lose formulas, preserve displayed values, though

V. 
Formatting a cell

V. Formatting text as in Word - font, font size, bold, italics, left right and center. Can select part of the contents of a cell and format only that part.

V. Auto formatting done when you type in a number including a symbol such as for %, $, / (date), : (time) but you can override these using Format / Cells...

V. Format > Cells… to format a selection. Common formats have ToolBar buttons.

V. Format numbers - different types (currency, percentage, etc.). Choose menu item Format > Cells... > Number

V. Some types of formatting apply only to numbers. These types are mainly on the Number, Currency, Accounting, Date, Time, Percentage, Fraction, Scientific, Special, Custom. If you apply formatting to more than one cell (column, row, rectangular selection), formatting that applies only to numbers will not be applied to any text cells within the selection.

V. Format Painter works as in Word - copy formatting from one cell to another by: 

V. Click in the cell with the right formatting to select it

V. Click on the Format Painter icon 
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V. Click in the cell that you want to format, to transfer the formatting using Format Painter

V. To transfer formatting to more than one cell, double-click on Format Painter, then use <esc> key to stop formatting

V. You can force a number to be treated as text by putting ‘ at the beginning

VI. 
Editing a cell (changing its contents)

VI. Can replace contents of a cell by clicking in it to select it and then typing the new content just as if you were entering data for the first time.

VI. Can remove all content from a cell by selecting it and tapping the <delete> key.

VI. Editing the contents of a cell: click in the cell, type <F2> - see the insertion point where typing will appear 

VI. Keyboard editing with arrow keys, <delete>, <backspace>

VI. Finish editing with <Enter> or by clicking in another cell, since the arrow keys are used for keyboard editing

VII. 
Formulae - calculate result in a cell based on numbers in other cells, for example adding or multiplying two cells

VII. ALL EXCEL FORMULAE BEGIN WITH "=". Could this be important on a test?

VII. Sum

VII. Enter Total in cell F7 as a label.

VII. Click in cell G7 to select it

VII. Type =sum(
VII. With the mouse, drag over the numbers you typed, from G2 to G6. Do not include any other cells.
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VII. Type ) (just the close parenthesis) to close the parentheses and tap the <Enter> key to finish entering the formula.

VII. The sum should equal $835,000.

VII. Other functions: average, min (minimum), max (maximum). Also many other functions - see textbook

VII. Also can do normal +, -, * (multiplication) and / (division).

VII. Example 1: If H4 contains the price of a book, and I4 contains the number of copies sold, then the total price is given by the formula =H4*I4 (this formula might go in J4)

VII. Example 2: If H4 contains the number of oranges, and I4 contains the number of apples, then the number of pieces of fruit is given by the formula =H4+I4.

VII. Excel follows the normal rules of algebra in combining math operations: multiplication and division are done first, then addition and subtraction. For example, if H4 contains 3, I4 contains 5 and J4 contains 2, the formula =H4*J4+I4 yields 17, not 21.

VII. As in algebra, control the order of computation using parentheses ( ). For example, =H4*(J4+I4) yields 21, not 17.

VII. A cell with a formula in it displays the result of the formula in the cell itself, but the formula bar displays the formula. The formula can be edited here.

VII. Excel will usually guess the formatting correctly, but you can override this by formatting the cell directly

VII. Ratio and percent 

VII. Now we will calculate what percentage each month is of the Sum or Total (Sum and Total mean the same thing here). The percentage is the part (sales for month) divided by the whole (Total), formatted as a percentage (if you are not in Excel, divide part by whole and multiply by 100 to find percent).

VII. Click in cell H1 and type the label Percent.

VII. Click in cell H2 and start a formula by typing =. Then click in cell G2 to put the cell reference for G2 into your formula (see figure below).
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VII. Finish the formula by typing the slash (/) for division, then click in cell G7 to put the reference to Total in the formula. Finally, type ) and tap <Enter> or an arrow key to enter the formula. The result should be as shown in the figure below. Notice that the formula bar shows the formula, but the numerical result is shown in the cell.
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VII. Format as percent. With cell H2 selected, choose the menu item Format > Cells > Percentage with 0 decimal places.
[image: image7.png]D E G H
2ix|| _ Percent
000 |_0.11976]

Narber | atgnment | Fone | sordr | pattoms | proectin | 000
Category: 000
000
000
Decinalplaces: [TS] a0

Percentage formats mulialy the cellvalue by 100 and dsplays the result with

a percent symbal

Cancel





The result should be as shown below. Note: Labels in Excel can be formatted just as you would in Word, except that you can only format an entire cell, not part of one.
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VII. Copying formulas - relative and absolute addressing. Now we want to fill in the formulas for the other months. Once you have entered one formula in a series, Excel makes it easy to copy and paste, for fill formulas into other cells in the series. Normally this works well, but here there will be a glitch, which will illustrate relative and absolute addressing in Excels. 

VII. To fill in the formulas, you can copy and paste using the clipboard, but here we will use Edit > Fill to do it in bulk. Click in cell H2 and drag down to H6 (not H7). then choose Edit > Fill > Down as shown in the figure below. Finish the formula fill by clicking on the Down sub-menu item.
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VII. Oops! See the whole column of #DIV/0!. This means that in the lower cells, Excel has a divide-by-zero error. Dividing by zero is illegal, as the answer is infinity. To see what the problem is, click in the first cell with the problem, H3, as shown in the figure below.
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The problem is that the formula in cell H3 says to divide cell G3 by G8, and we have nothing in cell G8, so Excel takes that as zero, giving the error. This is Excel's normal "Relative Addressing": since cell H3 (the cell we are copying to) is down one location from H2 (the cell we are copying from), then all the cell references in the formula are adjusted down one location. In the numerator, G2 is adjusted down to G3, which we want to have happen, but also cell G7 is adjusted down to cell G8, which we don't want to have happen, since the total is always in Cell G7. Relative addressing works for the numerator, but not for the denominator. We can, however, tell Excel not to adjust the cell reference to G7 by going back to cell H2 (click on cell H2) and typing a $ in front of the 7. This directs Excel to use "Absolute Addressing" for the 7; in other words, don't adjust it if copying to other cells. See the figure below. Tap <Enter> to enter the change. NOTE: You can insert the $ by either (a) clicking just before the 7 in the Formula bar as shown, or by tapping <F2> to edit the cell, and then using either the cell itself or the formula bar.
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VII. Now repeat the Edit > Fill > Down and it will work, as shown below. Notice that the percentage formatting is copied also.
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VII. Now copy and paste the sum formula from G7 to H7, to add up all of the percents. Since this copies the dollar formatting from G7, reformat cell H7 as a percentage with zero decimal places, as in C.5 above. The sum in H7 should be 100% after the formatting.

VII. Save your worksheet.

VII. Auditing cells. It can be difficult to check that a formula is correct. Excel's auditing tool helps out here. Use auditing by 

VII. Clicking in the cell whose formula you want to check, to select that cell

VII. Choosing the menu item Tools > Auditing > Trace Precedents (Precedents are the cells used in a formula). Blue arrows show which cells appear in the formula in the selected cell (see figure below, but you would not see the menus and arrows at the same time)
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VIII. 
Charts - Excel will make many different types of charts from the data in the worksheet

VIII. Drag over the Month and Sales figures in the worksheet above (cells F1 to G6) to select the data and the labels. See the figure below to double-check your selection.

VIII. Click on the chart toolbar button to get the Chart Wizard as shown. (A Wizard is a series of dialogs with numbered steps on title bar - definition could appear on tests!)
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VIII. Select Pie as the Chart type (highlighted) and the second example in the top row of Chart sub-types (highlighted), then click the Finish button to insert your chart on the worksheet. If a dialog appears, click its Close Box. Your chart should look like the one below.
Save your worksheet.
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VIII. Change one of the dollar figures by

VIII. Click in the cell to select it

VIII. You could just type a new number, but instead tap the <F2> key to edit the cell. You can use the arrow keys, Home, End, Delete and Backspace to position the cursor and delete digits, and then type in new digits. Make a big change; for example, double the figure for March. Tap the <Enter> key to accept your changes.

VIII. Notice that the total sales, the percentages and the chart all change to reflect the new value!

VIII. Save your worksheet.

IX. 
Copying and pasting between Office applications (and other applications)

IX. Copying 

IX. Your chart should still be selected (small black squares at the corners and the midpoints of each side). If not, click anywhere in the chart to select it.

IX. Copy the chart to the clipboard using any one of the keyboard (<Ctrl>C>, toolbar button ([image: image16.png]By Copy|



) or menu (Edit > Copy) methods.

IX. Pasting into Word (If your computer has less than 32 MB RAM, you may want to close the first application - Excel -  at this point, before opening the second - Word. The lab computers are fine, but your home computer may not be.)

IX. Open Word and type a simple letter explaining that here is the chart showing the monthly sales figures. Save your Word file to your floppy diskette.

IX. Put the insertion point in your Word document where you want the chart to go and paste the chart in using any one of the keyboard (<Ctrl>V), toolbar button ([image: image17.png]| Paste.



) or menu (Edit > Paste) methods.

IX. Save your file.

IX. More on pasting. 

IX. What you did above pastes the picture itself into the file. Suppose that next month you wanted to add June to the chart and write the memo again (this might be a monthly task for you). You would have to repeat the whole process.

IX. Alternately, when you pasted the chart into Word, using the Menu method, you could choose Paste Special... and paste a link into the Word file. The chart would appear on the screen exactly as before, but the chart itself would be pulled from the Excel file. If you now change the chart in Excel, when you open the Word document, it will pull in the changes. These links can be "fragile" however, since if you email the Word document to someone else, they won't have the Excel file and so the chart will not appear. The other person will think that you made a mistake. So, if you are going to email file or transfer them to other people, pasting the graphic directly is a better choice, instead of pasting a link.

X. 
More on charting in Excel. Excel charting is very flexible. You can choose many different types of charts in the Wizard, and many different sub-types. Also, after finishing with the Wizard, you can click on the chart to edit it in many more ways that the Wizard gives you access to.
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