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I. Starting the lab computers

A. Things always go better with Windows if you reboot. If you find your computer already on, you may think, “Great! One more thing I don’t have to do. But really, things will go better if you shut it down and reboot. Don’t say I didn’t warn you! (For shut-down instructions, see item IX below.)

B. The power button is on the main or system unit, about halfway down, in the middle. If the vertical bar shows green, your computer is already on. If the vertical bar is unlit, press the button to start the computer.

C. Let the computer boot until a window pops up saying to “press Ctrl-Alt-Del to start.” (If you do not see this window, go to Step F). This is a multi-key stroke, and is always done by holding down the first keys (all except the last one), then tapping the last key in the list (Del or Delete), then releasing all keys.

1. The login screen pops up. Enter the login information shown on the overhead projector.

D. With the login information entered, click OK or tap the <Enter> key

E. Now the “Windows desktop” appears. Computer startup is complete. Go to II (skip over the rest of the section you are in now).

F. (Start here only if you did not see a window saying, “Press Ctrl-Alt-Del to start.”) If your screen is dark, check the power light on the monitor (along the bottom of the monitor).

1. If the power light is not green, press the monitor power button to turn the monitor on.

2. If the power light is green, move the mouse to wake up the monitor.

G. Click the mouse on the “Start” button in the lower left of the screen. Slide the mouse up to “Shut down…” and click the left mouse button on “Shut down…” once.

H. The “Shut Down Windows” dialog appears. Click the mouse on the down-pointing arrow just to the right of the middle of the dialog, and then click the mouse on “Restart”

I. Click the “OK” button or tap the <Enter> key.

J. Go back to Step B and continue from there.

II. Signing in and out of class

A. Start a web browser (Internet Explorer, Firefox, or Mozilla)

1. Windows gives you several ways of starting a program such as a web browser. Any of the following methods will do:

a) You may see a browser icon on the desktop. Put the mouse on the icon and double-click the left button (click the button twice, quickly).

b) You may see a browser icon in the “Quick Start” section at the bottom left of the screen, just to the right of the “Start” button. Point the mouse at the icon and click the right button, once.

c) Click the mouse on the “Start” button in the lower left of the screen, slide the mouse up to “Programs”, then over to the left and down the list of programs to click on either browser.

B. Go to the course web site at and go to the course web site at http://www.is.wayne.edu/drbowen/casw07. Do this by clicking the mouse in the top white text box (labeled “Address” in Internet Explorer, or has a row of buttons beside it in Firefox and Mozilla). That should clear the text box and leave the insertion point (flashing vertical bar) inside the text box. Then type the web site address EXACTLY as it appears. Then tap the <Enter> key.

C. In the section “Online Tools”, click on the link “Sign in / sign out”

D. Fill in the form, select sign in or sign out as appropriate, and click on the button “Send My Information In”

E. You should get a confirmation screen that your login has been accepted. You can close the Browser at this point (click the mouse on the X at the top right of the browser screen).

III. Course overview

A. Syllabus

1. IST 2710, Computers and Society, carries CS General Education credit

a) Books are available at Barnes and Noble:

(1) Microsoft Office 2003 Professional
(2) Computers, Society and Technology
2. Labs

3. Assignments. NOTE: If we do not cover all of the material in the Agenda, some of the questions on the Assignment will be “deassigned.” Don’t worry – they will show up in the future!

4. Quizzes and Exams

5. Essay (specific assignment will be distributed later).

B. NOTE: The Labs are preparation for using Microsoft Office 2003 on the quizzes and Exams. If you work at home using other programs, you will not be able to do the computer work on the Quizzes and Exams. The Quizzes and Exams count much more than the labs. Therefore, it does not make sense to get the labs done using other programs. In windows, you can tell what programs you are using by clicking on the “Help” menu and selecting the last menu item (“About…”).

If you fall behind in turning the labs in, you may be required to stay during the lab period.

IV. Topics we will cover in class tonight:

A. User interfaces

B. Count and add in binary, and define or describe the terms bit and byte.

C. What is the difference between data, information and knowledge?

D. Describe the structure of a typical desktop computer

E. List and describe the different types of computer storage and the units in which they are measured

F. List and describe the types of information that can be stored in computers

G. Starting with the computer off, create, save, print and open a file in Word

V. User Interfaces: Command Line (example: DOS) Vs Graphical User Interface or GUI (example: Windows) 

A. What do we mean by "user interface" anyway? An interface is the method that a user employs to get the computer to do things like start a word processing program, save a file, or print a document

B. The characteristics of a command line interface: 

1. The computer does not display what it can do; instead, the user must know the commands.

2. To get the computer to do something, the user types in the name of the appropriate command.

3. Just the command is not enough; the computer does nothing until the command is entered with the <Enter> key.

4. If the command is mistyped (try mistyping dir below), the computer is not very helpful.

C. Using a command line interface: 

1. Click Start > Run, type "cmd" and tap the <Enter> key. This will open up a command-line or DOS window ([image: image1.png]CiN>—



). The flashing horizontal bar is the "prompt," meaning "type something." ("DOS" = "Disk Operating System," the first form of operating system for Intel-type computers.)

2. Type dir and then tap the <Enter> key. A list of files and folders is displayed.

3. Type exit and then tap the <Enter> key. The DOS window closes.

D. We have played around with the Windows GUI in several ways. The usual characteristics of a GUI are: 

1. The computer displays actions and files using letters and icons.

2. To get the computer to do something, the user selects the words or icons using a mouse.

E. An expected type of future interface is the agent - suggest/ask/remind, take commands, execute, report back with results, e.g. the Office Assistant is an early example.

VI. Binary 1 (handout)

VII. Introduction to Computers – handout Computer Structure and Information 1
VIII. Lab 1. For this first class, we will be using Word 2003.

A.  Start Word by

1. Clicking on the Start button in the lower left corner of the screen

2. Then pointing to Programs
3. Then sliding the mouse cursor over horizontally, then up-down to Microsoft Word ([image: image2.png]=]



) and clicking

a) NOTE 1: the Word icon may not be directly on the Programs menu, but in the Microsoft Office subgroup ([image: image3.png]) Microsoft Office



). The right arrowhead ([image: image4.png]


) indicates a subgroup will display when you slide the pointer over towards the right. In this case, slide the pointer to the right of the Office icon, then right into the subgroup and up or down to the Word icon, and then click on the Word icon as above. (Where the Word icon appears depends on how Office was installed on your computer.)

b) NOTE 2: you may also have a Word icon on your desktop. Since many people use the lab computers, sometimes maliciously, someone may delete the desktop icon just before you need it on an exam. So it is a good thing to be able to open programs from the Start menu, even though it takes a little longer.

B. Make sure your test floppy diskette is still in the drive

C. Just under the blue bar at the top of the Word window, click on the “Format” menu item, and then “Paragraph…”. On the tab “Indents and Spacing”, set up the following:

1. Alignment: click on the down-pointing arrowhead and select “Justified” (line up both the left and right margins)

2. Indentation: leave “Left” and “Right” at 0”, and set “Special” to “First line” and “by” to 0.6”. This automatically indents the first line of each paragraph by 0.6 inches.

3. Spacing: set “Before” to “6 pt” (about half a line), leaving “After” at “0 pt” and “Line spacing:” at “Single.” This will automatically put a 6-point space before each new paragraph.

When you have finished making these settings, click “OK.”

D. Click on “Format” again, then “Font” and then set up the following:

1. Set “Font” to “Arial” or “Arial New”

2. Leave “Font style” at “Regular.”

3. Set “Size” to 14.

When you have finished making these settings, click “OK.”

E. Type the following short document exactly as it appears below, including the text to the left of the colon. Tap the <Enter> key to start each new line – this also starts a new paragraph.
Course: IST 2710
Name: [type your name in this space]
Semester: Winter 2007
Assignment: Lab 1

F. Then tap <Enter> and retype the first paragraph I.A. at the top of this Agenda, the one about rebooting Windows.

G. Then hold down the Control key <Ctrl> and then, with <Ctrl> still down, tap <Enter> twice. This skips a full line, and then skips to a second line, without starting a new paragraph. and type the date.

H. Now tap the <Enter> key (without <Ctrl>) and type a short paragraph explaining how the paragraph formatting you set up above results in the appearance of your typing, including first-line indents and spacing before paragraphs.

I. Save what you have written by:

1. Click on the "File" menu item and then "Save As."

a) In the future, we will call this the menu item File > Save As...

b) NOTE: In "Save As..." the ellipsis (three dots at the end) indicates that you will need to supply further information to carry out the action. This is standard Windows usage. For one thing, it means that if you try it and don't like it, you will be able to cancel the action.

2. The "Save As" dialog opens.

a) NOTE: Always follow the path from left to right: drive first, then folder, then filename and extension. A primary cause for losing credit on Quizzes and Exams in this course is not controlling the drive and folder in which you save files; either forgetting where you put a file, or not putting it where the directions say. Always remember - drive first, then folder, then filename and extension.

”Keep your file safe tonight.
Walk the path from left to right.”


3. Locate the "Save In" line near the top of the dialog and the down-pointing arrowhead at the right side of this. Click on the down-pointing arrowhead and choose the 3½ Floppy drive (A:) by clicking on the drive icon ([image: image5.png]A 3% Floppy (A:)



) to the left of these words (clicking on the letters is apt to start the process for changing the name, which will be confusing). Notice that "Save In" is now showing the floppy diskette as the place where the file will be saved.

4. Click in the "File Name" line near the bottom of the dialog, type in a file name, for example WordClass1, being sure to leave the ".doc" just as you found it.

a) Always use the file name to remind you of what is in the file.

5. When the "Save As" dialog is set up as in #2 above, click on its "Save" button near the right side. You may see one or more of the following indications as the file is actually being saved: 

a) Light on beside the drive

b) Noise or vibration

c) Pulsating drive icon on the status bar or row of boxes marching across the status bar.

J. Reopen your file by:

1. Choose the menu item File / Open

2. Select the drive (A:), then either (both do the same thing)

a) Double click on the file name
OR

b) Single-click on the file name and click the OK button

K. Print the file and turn it in as your Lab Report.

L. Close your file but leave Word open.

1. In the upper right corner of the Word window, there are two sets of controls. Click on the lower "X" to close your file but leave Word open.

M. Close Word by clicking on the upper "X"

N. NOTE: You will make a similar cover sheet for each lab.

IX. Turning your computer off. 

A. Save any files that you have worked on during the class and still have open

B. Click on "Start" or tap the "Windows" button on the lower left of the keyboard, then "Turn Off Computer" (twice)

C. If you borrowed a diskette from the Instructor, be sure to return it.

X. Assignment 1 - turn in at the start of the second class. On each assignment, at the top, put your name, the class (Computers and Society Winter 2007) and the Assignment number (here, Assignment 1).

A. Write one definition each for the decimal number system and binary number system.

B. Write a description of what happens in a place value number system when you run out of number symbols in a column.

C. Write the three rules of binary addition and explain why the one involving zero is actually three rules.

D. In counting in binary, what number comes after each of the following binary numbers (that is, add 1 to each of the numbers below):

1. 100

2. 110

3. 111

4. 1001

5. 10111001101

E. Add the following binary numbers (NO CREDIT without showing your work (Carries) ):

1. 10 + 11

2. 1010 + 1101

3. 11 + 1

4. 11 + 10

5. 110011 + 1101

F. Why do computers use the binary system?

G. Why do humans use the decimal system?

H. What does the term "bit" refer to?

I. What does the term "byte" refer to?

J. Read Chapter 1 in Computers and Technology in a Changing Society. As part of Assignment 1, turn in answers for Key Terms on Pg 32. On quizzes and exams, be prepared to answer the Self-Quiz questions on Pg 33. Note that the Self-Quiz answers are given at the end of the book; for this reason, Self-Quizzes will never be assigned to turn in for homework.

K. Based on the reading, and using your own words, write a brief description of a computer, including each of its basic functions and a description of each function.

L. Based on the reading, and using your own words, write a brief response to the discussion question on Pg 33. 

M. Read the course Syllabus.

N. In Microsoft Office 2003 Professional, read the sections EC (Essential Computer Concepts) and WIN (Windows), and be prepared to carry them out in the lab period.
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