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I. Computer systems and software

A. Files

1. What is a file?

a) Collection of related information

b) Exists in secondary (permanent) storage (files downloaded over the Internet, email or other network do not exist in secondary storage unless and until you save them).

c) Has a name - filename and extension: filename.ext, at least in Windows. (Unix and Macintosh computers do not use file extensions.)

(1) Wildcards -- ? stands for any one character. * stands for any number of characters (including zero characters). For example, *.exe stands for a file with any name and an extension of exe. In Microsoft Excel, there are several file types, whose extensions start with xl. This can be indicated by *.xl*

(2) The filename identifies (or should) the content of the file for you, the user. When saving a file, Windows applications will propose a filename, but you should usually change this to describe the content for you, such as "SyllabusW03.htm"

(3) The extension, in Windows, tells the system which application created the file, and what type of file it is. Examples: *.doc is document produced by Microsoft Word, *.xls is a spreadsheet produced by Microsoft Excel, *.htm or *.html is a web page, and so forth. When saving a file, Windows applications will propose an extension. Do not change this proposed or default extension, or you may have trouble finding and opening the file.

2. Types of files

a) Program, for example, Microsoft word, the word-processing program you will be learning as part of this course

b) Data, for example a document that you write using Microsoft Word

3. Hierarchical file system. ("Hierarchical" means "like an outline," and with respect to files, refers to the existence of folders, sub-folders, sub-sub folders etc.)

a) Directories / folders. A directory can contain files and other directories (sub-directories), while a file contains data. Does a folder contain data? Only indirectly, in its files. The direct answer is, "No, a folder does not contain data."

b) Root directory is a special folder without a name that is the “root” or base of a secondary storage drive such as a: or c:

c) Examples:
C:\ (root folder for the c: drive
C:\STUDENTS
C:\STUDENTS\SECT571 

4. "Path" means path to a file, including the directory and file name. Example:
C:\STUDENTS\SECT571\PROSPECTUS.XLS  
On quizzes and exams, you will be asked to break this down into its parts. To do this, start and both ends and work towards the middle, as follows:

a) Left end: C: is the drive

b) Right end: The dot at the right separates the file name (to the left of the dot) and the extension (to the right of the dot). Here, the file name is “PROPSECTUS” and the extension is “XLS” (making this a Microsoft Excel document)

II. In Windows, you work with files directly using Windows Explorer (not Internet Explorer). Microsoft puts Windows Explorer in different places. Try Start > Programs > Accessories, then look for an icon that is a file folder with a blue magnifying glass on top ([image: image1.png]. Windows Explorer



). If there is a double-down arrowhead ([image: image2.png]


) at the bottom of the Accessories list, that means that Windows is hiding seldom-used items, and you should either (a) wait briefly until Windows decides to show all items, or (b) click on the down arrow to force showing all items immediately. If you don't see Windows Explorer in Accessories, try Programs itself (Start > Programs). 

A. Windows Explorer normally shows two halves or panes. A drives-and-folders pane on the left and a folders-and-files pane on the right. If you do not see the drives and folders on the left, click the Folders toolbar or use the menu item View > Explorer Bar > Folders. To hide the folders, click on the close box at the upper right of the left (drives-and-folders) pane.

III. Displaying files with Windows Explorer

A. Insert the test floppy diskette into the diskette drive.

1. The writing ("HD" for “High Density”) is on the top of the diskette. The metal door is on the front edge of the diskette. Put the diskette into the topside up and front first.

2. Push firmly until the computer takes the disk in the rest of the way. If the diskette sticks, do not force it.

B. By default, Windows Explorer hides most extensions from you, but in this course you will want to see the extensions. To raise the stakes, all applications (for example, Word, Excel, Access and Internet Explorer) follow the settings of Windows Explorer. Here is how to make Windows Explorer (and all other applications) show you file extensions: 

1. Choose the menu item Tools > Folder Options > View

2. Make sure that "Hide extensions for known file types" is unclicked. This will display file extensions. You could also guess the extension by the icon beside the file name.

3. When saving a file, if the extensions are displayed, DO NOT type or change the extension. If extensions are NOT displayed, do not type an extension either.

a) Editing the filename without changing the extension: move the insertion point with the arrow keys, delete with <Delete> and <Backspace>.

C. For this course, I also recommend having "Display the full path in the address bar" and "Display the full path in the title bar" clicked. This is because you will often be asked to save a files to a specified path, and having the path displayed makes it easy to use windows Explorer afterwards to check that you saved correctly.

D. To see all of the information for a file (name, size, date of last change, etc.) choose the menu item View > Details.

E. To apply these settings to all folders, click the "Apply to All Folders Button" (recommended for this course). Click the <OK> button

1. NOTE: As described above, these settings will change the way Word and the other Office applications save files, and you will need to recognize what these settings are on Quizzes and Exams. 

2. Path - drive, folder(s), file name, extension 

3. Root folder. If there is no folder shown in a path, that is the special folder called the root folder.

IV. Making folders using Windows Explorer 

A. If Windows Explorer is on the taskbar, click on its button to make it active. If not, open it from Start > Programs > Accessories etc.

B. In the Folders window on the left, scroll up and find the A: icon, and click on it to select it. What folder are you seeing now? The Root Folder.

C. Use the File > New > Folder menu item.

D. Notice that “New Folder” is highlighted (selected). “Typing Replaces Selection” means that if you just type now, “New Folder” will disappear to be replaced by what you type. Type a name for your new Folder, for example MyFirstFolder. Watch the screen as you do this.

1. You have made a folder within the root folder. File > New > Folder makes a new folder within the folder in the right pane of Windows Explorer – within the folder listed on the title bar (if you have clicked "Display the full path in the title bar")

E. Make a sub-folder as follows: 

1. Double-click on the icon for your new folder to open it. (Clicking on the letters is apt to start the process for changing the name, which will be confusing.)

2. Use the File > New > Folder menu item and type a name for your new sub-folder.

3. Notice that the sub-folder is inside the first folder. Again, File > New > Folder makes a new folder within the folder in the right pane of Windows Explorer – within the folder listed on the title bar.

F. Thinking about the hierarchical file system

1. How would you make a new top-level folder?

2. How would you make a sub-sub folder?

3. How would you make a new sub-folder at the same level as your first sub-folder?

V. Copying, deleting, moving and renaming files using Windows Explorer.

A. Download the files Test1.txt, Test2.txt, Test3.txt. Test4.tst and Test5.txt to the root folder of your floppy diskette from the IST 2710 web site for practice. These are pure ASCII text-only files. To download each one, right-click on it and choose to save the link target (or similar text) to the floppy diskette (A:\).

B. In Windows Explorer, in the left-hand pane, click on the floppy drive (A:\) to select it.

1. Highlight one of the Test files and click <Delete> to delete it.

2. Highlight another and choose Edit > Cut, then double-click on a folder on the floppy diskette, then click inside the right pane and choose Edit > Paste. You have moved the file to that folder.

3. Alternately, you can use Drag ‘N Drop to move a file.

a) If you are dragging to the same diskette, the default is Move. Hold down <Alt> during Drag’N Drop to copy the file.

b) The situation reverses if you are dragging to another disk. The default is Copy, hold down <Alt> to Move.

c) Alternately, use right-drag and choose the one you want fro the pop-up menu when you release the mouse button.

C. To rename a file or folder (DO NOT rename a file extension, although Windows will allow you to do this, after a warning).

1. In either pane, click once on the file icon or file name (right on the letters) to select it.

2. Do one of the three following items:

a) Wait, and click again (not a double-click, but two singles).

b) Choose File > Rename

c) Right-click on the file icon and choose Rename

3. Notice that the highlight shrinks to enclose the filename and extension only. Click inside the highlight to position the Insertion Point inside the file name. Use keyboard Editing (arrow keys, <Delete> and <Backspace> to change the file name. When you are done, click anywhere else, or tap <Enter> to actually make the change.

VI. Sorting files by name, size, date of creation

A. Click on the drive and/or folder you want to sort to view its contents in the right-hand pane.

B. In the right-hand pane, click on the column heading that you want to sort by (name, size, date of last change). Click once to sort in ascending order (alphabetic order for file names, smallest files first for file size, oldest first for date of last change) and click again to sort descending.

VII. Searching for Files using Windows Explorer. Can’t find that file? Windows Explorer can help you. But you must remember something about the file you are searching for – most importantly the drive, but the name and/or about when it was created help a lot also. What type of file (extension)? Can you remember part of the name? You can try sorting first, especially for files you have been working on recently. Double-click on the date heading to list newest files first. But back to searching:

A. In the right-hand pane, select the drive and folder that you want to search. If you don’t remember the folder, just select the drive. But you will save time if you remember the folder.

B. Either:

1. Right-click on the selected drive or folder and choose Search…

2. Choose the menu items File > drive/folder name > Search…

C. Fill in the search form as completely as possible. Notice that you will not be able to specify a file date unless you click the search by date box. The same is true for other criteria, aside from the name. Use wildcards (*, ?) for the name. Examples:

1. Search for all doc files – name = *.doc

2. A doc file containing “memo” somewhere in the name = *memo*.doc

3. A text file with a single number at the end = test?.txt (or test*.txt)

D. Click Search Now to carry out the search.

E. The search results display in a separate window.

1. Notice that you can copy/cut and paste between the search results window and the Windows Explorer window.

VIII. Launching a program from Windows Explorer

A. If you can find the exe file for the program (Word.exe for example), double-click on it to launch (start) the application.

B. To launch the program with a document open, find the document you want to open and double-click on it. This will start the associated program with the document open in it.

1. Windows opens the application based on the file extension. If this is a new extension for your copy of Windows, you will get a dialog asking which application you want to open the file with.
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